High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

Rear-Projection TVs CRT, DLP, LCD, LCOS

Hitachi 57F500 help. No picture as of today.

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 10-10-2005, 10:13 PM   #1  
My plasma is High Def.
Thread Starter
 

Join Date: Oct 2005
Posts: 5
Default Hitachi 57F500 help. No picture as of today.

I bought the hitachi 57F500 almost two years ago new from circuit city. I didnt go with the warrenty though.

Anyways, ive had no problems with this tv what so ever until today. I turn off the tv as usual and i heard a clicking noise coming from the behind the tv (I dont know if it was the tv or not because i have you know receivers, cable boxes, and video game systems) it sounded like it was coming from the power strip so i swiched it off and the noise stopped. About 10 minutes later I decided to use my tv again, turn it on and nothing, no picture, Just blackness. You couldnt even see volumn control. Plus another wierd thing was I could turn the tv on with the remote controller, but not off.

When I use remote the RED LED light comes on, but I get no picture and no sound. when I try and turn off, the remote doesn't work and the RED LED light stays on.


Anyone know what the problem could be?

Last edited by Italian Stalli; 10-10-2005 at 10:25 PM..
Italian Stalli is offline   Reply With Quote
Old 10-11-2005, 05:52 AM   #2  
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn..It's not a Place, it's an Attitude, & LI,NY
Posts: 23,619
Thumbs up

I know this is elementry but have you unplugged your set from the power supply wait a minute or two the plug it back in this sometimes resets the power system and memory systems of electronic components....Good luck

Last edited by ImRizzo; 10-11-2005 at 05:54 AM..
ImRizzo is offline   Reply With Quote
Old 10-11-2005, 09:06 AM   #3  
My plasma is High Def.
Thread Starter
 

Join Date: Oct 2005
Posts: 5
Default

yeah, ive tried that. Thanks though. I just wanna smack myself for not getting the warrenty.

Okay, if i cant find out the problem myself what steps should i take to getting it fixed? I dont wanna get ripped off.
Italian Stalli is offline   Reply With Quote
Old 10-11-2005, 06:04 PM   #4  
ISF Technician
 
d6500k's Avatar
 

Join Date: Jul 2005
Location: Oregon
Age: 66
Posts: 1,725
Default

I searched for a SB (service bulletin) and found none matching your description. In fact there are very few for this model.
I suggest you email Hitachi from their US site and explain your situ. It may be a really easy fix.

http://www.hitachi.us/

Good Viewing,

Doug k
d6500k is offline   Reply With Quote
Old 10-12-2005, 09:31 AM   #5  
My plasma is High Def.
Thread Starter
 

Join Date: Oct 2005
Posts: 5
Default

thanks.
Italian Stalli is offline   Reply With Quote
Old 10-13-2005, 03:12 PM   #6  
My plasma is High Def.
Thread Starter
 

Join Date: Oct 2005
Posts: 5
Default

I had someone come and fix it and paid $409.14 and it is not fixed.

The service charge along was $89.50.

What he replaced was 2 Power IC'S part no. 392-110-020

I was charge $285 for both of those. Was a ripped?
Italian Stalli is offline   Reply With Quote
Old 10-14-2005, 08:16 PM   #7  
ISF Technician
 
d6500k's Avatar
 

Join Date: Jul 2005
Location: Oregon
Age: 66
Posts: 1,725
Default

Absolutly get ahold of Hitachi ASAP through the site I listed above.

It better damn well work for 400.00 and they should know who worked on the display.

Hope it turns out ok,

Doug k
d6500k is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:54 AM.



Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004 - 2018, MH Sub I, LLC dba Internet Brands