High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

High Definition Receivers, Recorders, Players, Tivos Discuss High Definition Receivers, Recorders, Players, Tivos, etc. Post reviews ask questions, etc.

New Klipsch tower speakers, but now no bass from Sub

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 02-04-2020, 05:40 PM   #1  
What is HD?
Thread Starter
 

Join Date: Feb 2020
Posts: 2
Default New Klipsch tower speakers, but now no bass from Sub

Hello,

I hope someone out there can help me with this.

I got new Klipsch tower speakers with Atmos, "R-625A" to go with my Onkyo HT-R695 receiver. My previous speakers where smaller satellite type speakers and where ok. The bass from the sub was great.

But after hooking up my new klipsch tower speakers, there seems to be a real lack of bass coming from the sub and only really kicks in when i turn up the main volume past whats comfortable.

Crossover Settings:

L/R= Full Band " Klipsch R-625A"
Center= Full Band "large Klipsch Center channel R-34c"
Height= 180hz "As Per Dolby Atmos Spec"

LPF of LFE= 80hz

The sub does work, it can create some great bass and was working just fine before i switched to tower speakers.

Can anybody help me figure out why the bass sucks now! I miss the floor shacking when explosion go off during the movie.

Thanks
Will975 is offline   Reply With Quote
Old 02-20-2020, 08:22 AM   #2  
CASA Volunteer
 
teetertotter's Avatar
 

Join Date: Jan 2016
Location: Janesville, WI.
Posts: 208
Default

I see your Okyo has Accu EQ Room Calibration. Did you use? If used, was the volume level on the subwoofer at 1/2 volume b/4 calibration?

What is your Subwoofer POWER spec? 100W or more? What is the make and model of your subwoofer?

Last edited by teetertotter; 02-20-2020 at 08:35 AM..
teetertotter is offline   Reply With Quote
Old 02-20-2020, 08:48 AM   #3  
High Definition is the definition of life.
 

Join Date: Apr 2006
Posts: 272
Default

What were the settings before?

Did you set "Double Bass" to ON?

Double Bass(On)
This can be selected only when "Configuration" - "Subwoofer" is set to "Yes" and "Front" is set to "Full Band".
Boost bass output by feeding bass sounds from the front left and right, and center speakers to the subwoofer.
"On": Bass output will be boosted
"Off": Bass output will not be boosted•
Page 10 - advanced manual
https://www.intl.onkyo.com/downloads..._manual_en.pdf
InYourEyes2 is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:08 AM.



Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright ©2004 - 2018, MH Sub I, LLC dba Internet Brands