High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource > General Chit Chat > The High Definition Lounge
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

The High Definition Lounge Can't find a proper forum for your questions, comments, reviews, etc.? Post them here! RSS - The High Definition Lounge

Like Tree3Likes
  • 1 Post By ImRizzo
  • 1 Post By ImRizzo
  • 1 Post By ImRizzo

Fried Denon 3311CI

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 10-12-2018, 05:46 PM   #1
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default Fried Denon 3311CI

After a power surge and outage Tuesday my faithful treasured Denon 3311CI was cooked. Trying to get it repaired but there is a lack of quality repairers on Long Island. I called Best Buy's Magnolia shop repair center which is an off-premises facility with a 3 - 4 wk delay and an approx quote of $400-450. for power amp transformer. Replacement cost approx $1200.00.

__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100


Last edited by ImRizzo; 10-12-2018 at 06:14 PM..
ImRizzo is offline   Reply With Quote
Old 10-12-2018, 10:51 PM   #2
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,396
Default

Sounds like a good time to invest in a good UPS system.

A bit too late, but it will protect for the next time.
Terryl3 is offline   Reply With Quote
Old 10-12-2018, 10:54 PM   #3
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,396
Default

And then there is this one.

https://www.ebay.com/p/Denon-AVR-331...d=192491405482
Terryl3 is offline   Reply With Quote
Old 10-13-2018, 07:40 AM   #4
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default

Quote:
Originally Posted by Terryl3 View Post
Sounds like a good time to invest in a good UPS system.

A bit too late, but it will protect for the next time.
I have a Monster power center which didn't trip off so I'm thinking the beast died of natural causes just coincidental timing. I've been looking at a few on EBAY the only thing that scares meis the shipping, not the cost but the actual handling UPS on LI is not the best when it comes to handling.
Thanks for the heads up, I was hoping to find one closer to home so I could pick it up.
Terryl3 likes this.
__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100

ImRizzo is offline   Reply With Quote
Old 10-13-2018, 11:39 AM   #5
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,396
Default

I would be contacting Monster about this, they state that nothing can get through their protection centers.

Old style power transformers do not just suddenly go bad, it takes quite a power hit, or major overload to fry one.

If you think it is the power transformer and can find a part number for it, you may be able to find one to replace it from this place.

http://www.pacparts.com/parts/list.c...DENON/row/7501
Terryl3 is offline   Reply With Quote
Old 10-13-2018, 12:56 PM   #6
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default

I found a high-end Audio-Video repairer he says that the high power Denon units have been known to experience this kinda problem he's awaiting Denon to get back to him with repl cost. I also contacted that ebay seller with my concern with shipping re: packing.
__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100

ImRizzo is offline   Reply With Quote
Old 10-15-2018, 11:08 AM   #7
I bleed for HD
 

Join Date: Nov 2007
Location: Ohio
Posts: 14,170
Default

Rizzo, accidently touched two speaker wires together when moving stuff and AVR was on (idiot me) heard a huge 'pop' and now my Marantz is in red light flashing protection mode. Blew something. Gonna go back to my Pioneer Elite AVR in storage until I figure something out or get a repair cost.
__________________
HT- 55" Sony 850c 4K HDR TV, Panasonic PT-AE8000 LCD projector, Elite Vmax Electric 100' screen, Pioneer Elite SC-71 AVR, Paradigm Titan Monitor v5 fronts, Paradigm CC-190 v6 center, Paradigm Atom Monitors v5 surrounds(x4), HSU research VTF-2 sub, Bowers + Wilkins ASW610 sub, HTPC/Gaming rig, Samsung 4K BDP, DirectTV HD-DVR, Roku 2, PS4,

Bedroom: RCA 40" 1080p, BD-player
Den - SEIKI 42" 4K LCD + RCA BDP


Don't believe everything you read on the internet - Albert Einstein
jkkyler is offline   Reply With Quote
Old 10-15-2018, 01:00 PM   #8
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default

Heard from repair shop the problem was in the HDMI circuitry evidently it was passed thru the cable box cable via the HDMI output and that was the reason the Powerprotector was not included. I just ordered a new Denon AVRS540BT from accessories-4-less due in on Thur. Also just switched to Altice one cable service.
Terryl3 likes this.
__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100

ImRizzo is offline   Reply With Quote
Old 10-16-2018, 09:57 AM   #9
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,396
Default

If it came in via the HDMI source then get one of these hummers.

https://www.amazon.com/Sewell-Direct.../dp/B00YFSPXP0

Well worth the price.(don't forget to ground it)
Terryl3 is offline   Reply With Quote
Old 10-16-2018, 10:24 AM   #10
High Definition is the definition of life.
 

Join Date: Apr 2006
Posts: 104
Default

It may be a good idea to look further into the product:


Question:

How do you property ground the unit? It comes with a ground cable but no instructions.

Answer:
You can't from what I can tell. Its snake oil.

By Mpire on August 31, 2016


I grounded to the AC ground in the outlet by using a grounded plug and only attaching the ground wire.

By Mackiver on August 31, 2016

Connect the loose end to something that is connected to ground.

By Wong Kee Meng on September 1, 2016
InYourEyes2 is offline   Reply With Quote
Old 10-16-2018, 02:48 PM   #11
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,396
Default

If you have a satellite receiver or cable box, then it's coax shield is grounded, you can then get a ground block (make sure it's made for a satellite system if your using that one) and then run a ground wire up to the AV receivers ground connection.

Or if the AV receiver has an FM antenna input then the ground on the coax shield from that will do the trick.
And lastly if the AC wall socket if a 3 way type (U shaped ground socket) then the center screw is a good ground, but you may need to remove any paint form the bottom of the screw head, and I would also use a wire connector that will keep any loose wire out of the AC sockets.(if you use stranded wire)



DO NOT use the AC neutral as a ground.......This is a no no.
Terryl3 is offline   Reply With Quote
Old 10-16-2018, 02:59 PM   #12
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default

getting the new Altice system via cablevision
https://www.optimum.com/alticeone
__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100

ImRizzo is offline   Reply With Quote
Old 10-24-2018, 04:44 PM   #13
HDF SUPER-MODERATOR
 
ImRizzo's Avatar
 

Join Date: Aug 2005
Location: Brooklyn & LI,NY ..not a Place, it's an Attitude, *I'm Mixing up a fresh pitcher of KoolAid
Posts: 23,156
Default

Optimum services installed their Premier package Altice 1 on Wednesday last week what a disastrous situation, it took their tech an hour and a half to get it up and running. Once he left I was checking out the functions like, 'voice activated' and other functions I had to run out so I turned off the system, when I returned I turned it on and was affronted with an error code "no signal available" I called service then went into the box via online connection to check problems and they did a full reset, and it worked again......till the next time I tried to shut it down and it wouldn't turnoff. The next morning I had call svc again they had me do a 'hard' reset holding down the on/off switch for 10 seconds, after which it did another reset. Only to experience the same problem, they scheduled another service appt, the tech came out checked it out again (another reset) and he also told me it was the HDMI cable, which he replaced, and experienced the same problem (error code requested an input check because it was not recognizing HDMI2 input, so he disconnected my firestick from HDMI4 because the input check up was indicating HDMI 1 OR 2 was not working ???. Now I was getting pissed and told him to take box out and replace with a new one, which he said he was not allowed to until he exhausted all other attempts. He got the set working using HDMI4 because 1 & 2 were no loger functioning ???? When he left I turned off the tv switched the cable to HDMI1 and turned the set on and it worked till I tried to turn the box off again NG. I called service and told them I want to discontinue their service they apologized and switched me to customer retention who asked me for a chance to resolve the problem and offered me 10% per month reduction of fees for 1 year, I agreed and they rescheduled for 2 days later (Sunday) the tech came out did a complete reset and told me the problem was the newer remote (with NETFLIX) was experiencing problems so he gave me a different remote. All was working till I tried to turn off the set -to no avail- and once again the apologies flowed. I told them one more chance but only to include a NEW replacement box to which they agreed. When the tech arrived he insisted on trying a full reload, I was pissed and called service again while waiting for the service rep to respond the tech said
'holy shit this box is fuq'd up, it was turning itself off and on and showing several error messages. he went out to his truck and brought in a new box and installed it and reprogramed it and finally everything worked, it was, as I originally stated a faulty box. I also noted a significant difference in PQ. So now after 3 days, all is well, but what a hassle. I explained to all of them that I'm more than familiar with the functions and operations and was 'blown off' by all of them except the last guy, he explained every step he was doing and he didn't talk down to me which I appreciated, he also explained that he had installed several hundreds of these and hadn't ever experienced problems like this.
I thanked him and threw him a 10 in appreciation which he tried refusing but I insisted, well worth it. I was called later that day by a service mgr inquiring if everything was resolved satisfactorily which I confirmed and also touted the professionalism of the tech.
InYourEyes2 likes this.
__________________
*
LG OLED-55B6P~Oppo UDP203~Sony XBR929~Denon S540BT~Mirage Omnisat V2 Spks w/S10SW~DVP5000~Harmony1100

ImRizzo is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource > General Chit Chat > The High Definition Lounge
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:53 PM.



Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2004 - 2018, MH Sub I, LLC dba Internet Brands