High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

DISH Network Forum Discuss and learn about Dish Network High Definition Satellite TV. Do not put referral code posts in this forum as they will be treated as SPAM. Thank you.

all channels no picture but has audio

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 10-15-2018, 07:31 AM   #1  
Space Man
Thread Starter
 

Join Date: Dec 2005
Location: Uniontown,Pa.
Age: 74
Posts: 1
Default all channels no picture but has audio

this has been going on and off for about three weeks called dish they said reset receiver did this a lot called again no help there teck support is not very good called again friday they said i can have no one come out to my house till wednesday .I have a 211 receiver they want to send me something i do not want i think a walley receiver,my wife called dish about this and they were talking over her. she did not like their attitude. she told them we cant even watch our steelers today. then she told them about the 300 dollar gift card direct tv was giving if we changed to them. he connected her to someone else then they hung up on her. bad customer service and i pay for maintance every month had to push for service to come to our home. pure disgust is what i feel right now. 20 years with dish and treated like this. bad for them.
space man is offline   Reply With Quote
Old 10-15-2018, 11:29 AM   #2  
Yellow Submarine
 
jim5506's Avatar
 

Join Date: Dec 2004
Location: Lubbock, Texas
Posts: 3,693
Default

Have you unplugged the HDMI cable and reconnected it?

Have you unplugged the receiver and restarted it?

You seem to not want to listen to anyone - you want a miracle.

Perhaps your receiver's video has failed and it needs to be replaced - the 211 is at least 10 years old and the Wally is the updated replacement for the 211.
jim5506 is offline   Reply With Quote
Old 10-15-2018, 12:44 PM   #3  
High Definition is the definition of life.
 

Join Date: Apr 2006
Posts: 232
Default

Try a different video output (component, composite, S-video)?
InYourEyes2 is offline   Reply With Quote
Old 10-04-2019, 07:01 AM   #4  
What is HD?
 

Join Date: Jul 2019
Posts: 2
Default

I am also facing this issue, All the cable connections are good.
dragontattoo is offline   Reply With Quote
Old 10-04-2019, 09:11 AM   #5  
High Definition is the definition of life.
 
Terryl3's Avatar
 

Join Date: May 2013
Location: Deep in the Duraflame National Forest
Posts: 1,558
Default

Press and hold the power button on the receiver for at least 10 to 20 seconds then release it, once it comes back online (2 to 10 minuets) it should be OK.

If no video after this then the RX needs replacing.
Terryl3 is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource >
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:39 PM.



Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004 - 2018, MH Sub I, LLC dba Internet Brands