High Def Forum
Thank you for visiting. This is our website archive. Please visit our main website by clicking the logo above.

Green screen on my television today

bodean
08-02-2008, 06:26 PM
Any ideas? I have my charter digital cable box hooked to my receiver via hdmi.

Yesterday it works, today I turn on the cable, green screen. I can change inputs on my receiver, and my xbox 360 works fine.
When I am on HDMI 1 (my cable) and I try to access the menu from the remote, nothing on screen appears, just a green screen.

Any suggestions?

mytime
08-02-2008, 06:29 PM
Any ideas? I have my charter digital cable box hooked to my receiver via hdmi.

Yesterday it works, today I turn on the cable, green screen. I can change inputs on my receiver, and my xbox 360 works fine.
When I am on HDMI 1 (my cable) and I try to access the menu from the remote, nothing on screen appears, just a green screen.

Any suggestions?

Might be a handshake issue. Also is there a reset button? Try resetting the receiver. If that does not work give charter a call.

bodean
08-02-2008, 06:36 PM
Reset my audio receiver?

mytime
08-02-2008, 06:39 PM
Reset my audio receiver?

I'm sorry I assume you have a Digital Cable receiver. My receiver from Charter has a reset button on it. When I have a problem with it I reset it and everything seems to work. :hithere:

bodean
08-02-2008, 06:41 PM
BTW I get the audio from the cable tv stations, just no picture (green screen)

bodean
08-02-2008, 06:44 PM
My Digital cable box is model DCH3200

mytime
08-02-2008, 06:48 PM
I see. I have a Motorola HD dvr. Yours might be different. Have you tried disconnecting the HDMI and REconnecting?

bodean
08-02-2008, 06:55 PM
Yes. Also tried just running 2 different HDMI cables from cable box to tv. Same thing. Box might be bad?

mytime
08-02-2008, 06:58 PM
Yes. Also tried just running 2 different HDMI cables from cable box to tv. Same thing. Box might be bad?

Maybe. If you have a local Charter office go there. You will get a new box much faster. Throw a fit if they try to charge you.

joekewl1971
08-02-2008, 07:03 PM
Did you try unplugging the power to the cable box? HDMI seems to work better if you unplug the box, connect the HDMI, then plug the box back in. The HDMI comes first, then the power to the box. If this does not permanently solve the problem, unplugging the box again might help. I know how inconvenient this is. Whenever I have problems, I do this. Sometimes my DVR freezes up and does nothing. If the HDMI proves to be too inconvenient, you should switch to component cables. You are not likely to see a difference in picture quality. I think in theory, digital HDMI is better. In reality, I can not tell the difference. Hope you get it worked out.

jjufon
08-03-2008, 03:54 AM
switching between the two tuners worked for me.

TomCat4680
08-23-2008, 08:22 AM
i've had the green screen problem before. i just pressed the guide button and it stopped.

Loves2Watch
08-23-2008, 09:40 AM
You could also try using component cables and see if you get a picture with them.