High Def Forum
Thank you for visiting. This is our website archive. Please visit our main website by clicking the logo above.

JVC HDILA 52Z575...Problems

stingray75
02-13-2006, 07:45 PM
Hi all...This is my first time posting here.

Anyway...in Dec. 2004 I purchased a JVC HDILA 52Z575. The first lamp went out in June 2005...at this time the recall upgrade was done. The second lamp went out in November 2005...and now I had red flashing vertical lines in the picture for two days...along with a green tint to the picture...before the third lamp went out. I don't watch a lot of TV...I don't understand what is going on here. I know that the lamp is a consumable item...but this is unbelievable. Three lamps in 13 months?? JVC said that if the last lamp replaced went out prematurely that they would do something about it. I will not accept anything other than JVC replacing the set. I do not want internal parts replaced, etc... I paid $3,000 for this unit and I expected it to perform much better than this. The local technician said that mine is the only one that has blown three lamps so far that they sold.

Has anybody else had problems like this with their JVC?

Thanks,
s75

Camdogg
02-14-2006, 10:36 AM
I had a bulb blow at 10 months. No other problems, though, and none since. Pressure them to give you a new set. Those first production models (built August 2004 and prior) had some problems and it could be that in yours the problems have lingered and affected other things causing your bulbs to blow faster. Tell them this is ridiculus and you want a new set as this one is obviously a lemon.

stingray75
02-14-2006, 05:56 PM
I had a bulb blow at 10 months. No other problems, though, and none since. Pressure them to give you a new set. Those first production models (built August 2004 and prior) had some problems and it could be that in yours the problems have lingered and affected other things causing your bulbs to blow faster. Tell them this is ridiculus and you want a new set as this one is obviously a lemon.

Camdogg,

Thanks for the reply. I plan on pressuring them. The service tech said that they may offer to replace all internal components and I said that is totally unacceptable to me. I will not settle for less than the unit being replaced...and if they refuse to replace it, I will take the appropriate steps necessary to see that they do replace it. The set has not worked properly since I bought it. When the lamp went out in November... I only had a little over a month left on the factory warranty. The service tech received an e-mail from them saying that if another lamp went out prematurely...they would do something...and at that time the tech stated replacing the unit...even after the factory warranty was expired.

Thanks,
s75

Camdogg
02-15-2006, 11:05 AM
If they won't give you a new unit, try to get something in writing that states they would replace the unit. Either that email or something new for next time. If you have something in writing, they can't really deny it.

Sorry about your problems.