High Def Forum
Thank you for visiting. This is our website archive. Please visit our main website by clicking the logo above.

DISH 722k - quit working in Dual Mode

susie-s
01-11-2012, 06:31 PM
For some reason, this evening the 722k receiver just quit working in dual mode. TV1 was off all day, we watched TV2. Evening news time, switched on TV1 - no picture, although the guide and menu came up. I went thru the diagnostics, just looking... everything said OK. Then suddenly, the picture did come up on TV1 but immediately TV2 went blank. I switched it to Single Mode, which shows same thing on TV1 and TV2.

What happened?

I also have a Sling Adapter hooked up to TV1, and it works fine, was watching a DVR show on my iPad with it last night. Could that have done something hinky?

Thanks.
Susie

MattG DISH
01-11-2012, 06:49 PM
Hi Susie, and welcome to the forums!

Have you tried unplugging your receiver for 15 seconds to reset it? The sling adapter would not be affecting the receiver in this way (the sling adapter feed always takes over TV2, and only TV2).

susie-s
01-12-2012, 08:28 AM
Matt, yes, that did the trick!

I thought it was an odd glitch to happen.
Could it mean the receiver may be going bad? I've had it for about 3 years.
Thanks for the help!
Susie

01-12-2012, 08:53 AM
Although there are many components within the receiver, generally if the receiver starts to go bad, you will lose some functionality on the receiver, such as pause, rewind, won't playback on a recorded event, and so on. As long as this incident or other things don't consistently occur, you shouldn't have to worry about your receiver. If you do have other problems or questions, please let us know. Thanks.