High Def Forum
Thank you for visiting. This is our website archive. Please visit our main website by clicking the logo above.

Help! Hitachi PJ-TX100 can't display HD?

sponsz
05-07-2011, 05:52 AM
Hi,

Wondering if anyone who owns a Hitachi PJ-TX100 may be able to help me please.

I've finally upgraded to a Blu Ray DVD player (got an LG BD560), but my projector shows no image at all when I connect it up via an HDMI -> DVI-D cable. Component working fine (although you can't view HD resolution over component, it seems, due to copyright protection).

The same HDMI -> DVI-D cable, plugged into my computer screen, shows an image perfectly, and I've tried 2 different cables. So the problem presumably lies with the projector.

I've tried all the different resolution and colour settings on both the projector and the player (although 720p is what it should be) - nothing! The DVI-D input is HDCP compliant, and I get this problem on the Blu Ray menu screen as well as when I try to play Blu Rays, so it's not a copy protection issue.

Really hoping I can get this sorted as don't want to have to sink another grand on a new projector just because my old Hitachi is being difficult about HD input!

Thanks for your help.

Loves2Watch
05-07-2011, 08:07 AM
I would recommend contacting Hitachi to see if there is a firmware update available for your projector. Do the same with your LG Blur-ay player.

sponsz
05-07-2011, 08:13 AM
Thanks for the reply.

The Blu-Ray player has fully up to date firmware. The Hitachi projector never had a firmware update issued.

sponsz
05-07-2011, 11:02 AM
UPDATE: FIXED IT!

Turned out it WAS the cable. Tried 2 different HDMI -> DVI-D cables, neither worked. But an HDMI -> HDMI cable with an HDMI -> DVI adapter finally worked.

Only difference I can see is that the adaptor doesn't have the middle set of DVI-D pins, but these were redundant anyway according to my projector tech specs.

Anyway, just goes to show that even if you've already tried 2 cables, they might still be the problem!

Loves2Watch
05-07-2011, 11:11 AM
Glad it worked out for you. The adapter had the correct pins for your connection and the cable with the DVI end somehow didn't which caused a handshake dilemma.