High Def Forum
Thank you for visiting. This is our website archive. Please visit our main website by clicking the logo above.

Not always turning on...

cartisdm
04-22-2010, 12:13 PM
I have a Polaroid 37" LCD tv. It's only about 3 years old, but I have roommates in college so unfortunately it gets turns on/off a lot. Last week I noticed one time I turned on my TV it made a really weird feedback-like static noise from the speakers while it was "warming up" (lasted about 10 seconds).

Yesterday, I tried to turn on my TV and it simply wouldn't turn on. The little blue light came on, but that was it. It was like it wanted to boot up, but just couldn't. After unplugging it a few times it finally gave in and turned on. Now it's gotten to the point were it will only come on after like 12 or more attempts. The sound never kicks in unless the picture comes up. I don't know a lot about TVs but if there is something like a "starter" then I would imagine it's gone bad...

Any ideas?

PFC5
04-22-2010, 01:35 PM
It could be the power supply is going. Try leaving the power unplugged for 2 hours and see if that resets something. It may help and is free to try.

cartisdm
04-23-2010, 05:49 AM
It could be the power supply is going. Try leaving the power unplugged for 2 hours and see if that resets something. It may help and is free to try.

Doing that seems to help improve its ability to turn on. So....is that an expensive fix? I don't know a lot about TVs, but I do a lot of laptop repair so I am comfortable working around a circuit board. Is this something I could order and install myself?


EDIT: After some more research, I found that you can replace the capacitors. That may be something I will try, any suggestions on doing that? Tomorrow I will open up the back of the TV to see if they capacitors look bulged at all