High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Rear-Projection TVs
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

Rear-Projection TVs CRT, DLP, LCD, LCOS RSS - Rear-Projection TVs

HDMI port on my DLP stopped working

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 11-27-2007, 10:19 AM   #1
Madeucher
 

Join Date: Oct 2007
Location: Maryland
Posts: 11
Default HDMI port on my DLP stopped working

I have a Mitsubishi WD-62525. I've been using the HDMI port the entire 4 years I've had it. Since there is only one HDMI port I only have my FIOS DVR hooked up to it. It started not working(the TV just has the blue screen like there's no input) 10 days ago. The Verizon tech came out and said there is a known issue with the HDMI just giving up. So I believed him and hooked it up with the component video. I later remembered I had a 2nd HDMI cable and I tried it, same blue screen. Then I tried both cables on the HDMI of my DVD player, same blue screen(plus the HDMI "light" on the DVD player never came on). So it's not the DVR or the DVD player, it must be the port on the TV, right? Is that something easily fixed? I've placed an email to Mitsubishi and I'm not holding my breath for a reply. Plus, I get better info from this forum all the time. Thanks.
madukrainian is offline   Reply With Quote
Old 11-28-2007, 11:55 AM   #2
And I use to watch SD
 
treker's Avatar
 

Join Date: Mar 2006
Location: Massanutten,Va
Age: 62
Posts: 566
Default

Did you try powering the set down completely(unplug)?. Then powering up you components again. Some time there can be a "handshake issue" with HDMI.
treker is offline   Reply With Quote
Old 11-29-2007, 08:24 AM   #3
Madeucher
 

Join Date: Oct 2007
Location: Maryland
Posts: 11
Default I'll try that......

Crap, I know that I should have tried that 1st. I did press the system reset button but not that.

Thanks.
madukrainian is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Rear-Projection TVs
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads to HDMI port on my DLP stopped working
Thread Thread Starter Forum Replies Last Post
DVI vs. HDMI vs. Component Video -- Which is Better? mrm64 DirecTV Forum 9 08-08-2008 07:41 AM
HDMI 1.3 - Is It Necessary? Lee Stewart High Definition Media 35 01-24-2008 09:40 PM
HDMI not working with 1080P gatorblair Cables & Connections 11 11-27-2007 07:47 AM
XA2 and HDMI sound oddity ClashFan HD DVD Players and Discs 12 10-15-2007 03:20 PM
Hdmi Explained lifestylestore Cables & Connections 3 08-20-2007 09:06 PM


All times are GMT -6. The time now is 05:54 AM.



Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2004 - 2008, High Def Forum