High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Rear-Projection TVs
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

Rear-Projection TVs CRT, DLP, LCD, LCOS RSS - Rear-Projection TVs

Does Mitsubishi Error Code 66 = Bad Lamp ??

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 03-07-2011, 05:52 PM   #1
What is HD?
 

Join Date: Mar 2011
Posts: 3
Default Does Mitsubishi Error Code 66 = Bad Lamp ??

Hi - I'm new to the forum and this one may be common knowledge..
My WD-52631 DLP doesn't produce a picture when turning on. I hear a noise like a fan (could be the color wheel) running through what sounds like two cycles, 20 seconds after the 2nd cycle the power goes off. I was able to use INPUT & MENU to get a code 66 via the blinks. The lamp light is not lit on the front panel. Does the 66 code mean the lamp needs to be replaced? I found the following error code info. but am unsure what to make of these especially the last two (No Lamp inserted) (Disconnected cable between ballast and lamp) (Lamp-enable goes to DM but not to ballast). The TV is about 4 years old, not used much and hasn't had any fading of colors thus far. Has seemed slow to turn-on in the past few months. THANKS IN ADVANCE

Last edited by tele10; 03-07-2011 at 05:54 PM. Reason: spelling error
tele10 is offline   Reply With Quote
Old 03-07-2011, 06:20 PM   #2
"Shitter was Full"
 
Bigloww's Avatar
 

Join Date: Apr 2006
Location: In a van, down by the river.
Posts: 8,322
Default

From what I seen on the web and the issue you described, sounds like a lamp to me.. Being 4 years old sounds about rite too.. Give it a try..

What I seen on the web..

"The code you are recieving is a code 66, which is failure of lamp to start, there are 2 main causes of this - the lamp being bad, or the ballast board that actually "lights" the lamp is bad.



I Would suggest changing the Lamp, and seeing if it still gives the error code, If so, then the Ballast has gone bad. ''



Read more: TV Questions - So i have a Mitsubishi WD-65733 that has worked perfect for - JustAnswer http://www.justanswer.com/tv-repair/...#ixzz1FxzGBGEO

A new lamp is about $100 shipped (make sure it is the correct lamp)..

http://www.amazon.com/Electrified-91...9547306&sr=8-4
__________________
Commit to the Indian..

"I don't get drunk, I get awesome"..

Last edited by Bigloww; 03-07-2011 at 06:24 PM.
Bigloww is offline   Reply With Quote
Old 03-13-2011, 05:44 PM   #3
What is HD?
 

Join Date: Mar 2011
Posts: 3
Default

Thanks BIGLOWW!! The error code was most definitely related to a bad lamp. For those researching DLP Lamp replacements: the lamp went bad, showed no signs of a degredated picture/color, only a slower than previous 3+ years time to turn on...
tele10 is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Rear-Projection TVs
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -6. The time now is 12:23 AM.



Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2004 - 2008, High Def Forum