High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Hardware > High Definition Receivers, Recorders, Players, Tivos
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

High Definition Receivers, Recorders, Players, Tivos Discuss High Definition Receivers, Recorders, Players, Tivos, etc. Post reviews ask questions, etc. RSS - High Definition Receivers, Recorders, Players, Tivo's

Digital Optical Audio not working for TV sound through A/V receiver

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 01-25-2008, 03:54 PM   #1
HD in Tennessee
 

Join Date: Jan 2008
Posts: 1
Default Digital Optical Audio not working for TV sound through A/V receiver

I have a Comcast HD cable box Motorola DCH3200 with digital optical audio out. I have connected that to a Samsung HT-X50 all-in-1 A/V receiver. I have a Vizio VX32L HDTV capable of 1080i.

When I connect the optical cable, the connection isn't very tight but I can hold it in using tape. I get the red glow on the end that goes into the A/V receiver so I'm sure a signal is being passed from the cable box to the receiver. However, when I am watching TV and I have the A/V receiver set to Digital In, I get no sound through my speakers. They work fine with CDs and DVDs so I know the speakers are connected properly. The connection from the cable box to the TV is via HDMI. The video connection from the receiver to the TV is via component cables. I realize I won't get "surround sound" when watching TV but I should be able to at least get front and rear speaker sound by using Digital In, shouldn't I? Even if I get the TV speaker sound PLUS the A/V speakers, I can mute the TV speakers. Am I missing another, simple connection? Thanks very much.
stutenn is offline   Reply With Quote
Old 01-25-2008, 04:20 PM   #2
Football in HD, mmm good!
 
deadhead68's Avatar
 

Join Date: Jan 2006
Location: Crystal Lake, IL
Posts: 2,923
Default

Quote:
Originally Posted by stutenn View Post
I have a Comcast HD cable box Motorola DCH3200 with digital optical audio out. I have connected that to a Samsung HT-X50 all-in-1 A/V receiver. I have a Vizio VX32L HDTV capable of 1080i.

When I connect the optical cable, the connection isn't very tight but I can hold it in using tape. I get the red glow on the end that goes into the A/V receiver so I'm sure a signal is being passed from the cable box to the receiver. However, when I am watching TV and I have the A/V receiver set to Digital In, I get no sound through my speakers. They work fine with CDs and DVDs so I know the speakers are connected properly. The connection from the cable box to the TV is via HDMI. The video connection from the receiver to the TV is via component cables. I realize I won't get "surround sound" when watching TV but I should be able to at least get front and rear speaker sound by using Digital In, shouldn't I? Even if I get the TV speaker sound PLUS the A/V speakers, I can mute the TV speakers. Am I missing another, simple connection? Thanks very much.
A couple of ideas:

Bad optical cable
Bad digital in port on receiver
Bad digital our port on Moto box
The Moto box may be only sending the audio out the HDMI. Check audio set up to see there's a setting to get the box to send the audio out both.

DeadHead68
__________________
Panasonic TC-P46X3
HR24-500
Sony STR-DG810 Receiver
Sony BDP-S360
Denon SYS-76HT Speaker System
Harmony 650
deadhead68 is offline   Reply With Quote
Sponsored Links
Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Hardware > High Definition Receivers, Recorders, Players, Tivos
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads to Digital Optical Audio not working for TV sound through A/V receiver
Thread Thread Starter Forum Replies Last Post
HDMI audio vs Optical Audio dustyjnz Speakers & Surround Sound 16 11-04-2012 08:00 AM
VIP622 non-HD channel audio loss hiller DISH Network Forum 13 03-03-2009 12:21 AM
Anyone running a Yamaha V663 & Sony S350? drdoom718 High Definition Receivers, Recorders, Players, Tivos 18 02-10-2009 09:05 PM
HDMI 1.3 - Is It Necessary? Lee Stewart High Definition Media 35 01-24-2008 09:40 PM
DCT-6412 box questions cb2367 Cable Providers 13 12-17-2007 10:34 PM
Comcast HD/DVR Dual Tuner (Motorola DCT 6412) & OPTICAL PROBLEMS? Willb Cable Providers 11 12-31-2005 01:57 PM


All times are GMT -6. The time now is 01:44 PM.



Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2004 - 2008, High Def Forum