High Def Forum - Your High Definition Community & High Definition Resource

Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Flat-Panel TVs
Rules HDTV Forum Gallery LINK TO US! RSS - High Def Forum AddThis Feed Button AddThis Social Bookmark Button Groups

Flat-Panel TVs Plasma, LCD RSS - Flat-Panel TVs

Mitsubishi LT-46164 issue...

Reply
AddThis Social Bookmark Button
 
Thread Tools
Old 04-29-2012, 06:11 PM   #1
What is HD?
 

Join Date: Apr 2012
Posts: 1
Default Mitsubishi LT-46164 issue...

A local TV shop threw away a Mitsubishi LT-46164 and I managed to snag it prior to it getting taken by the trash guys; it had a sticker on it that said "BAD MOBO"...

Well, I looked through some troubleshooting guides, and I powered on the device and saw the blinking light (of death) and performed a reset on the device by holding the power button down for 10 seconds and turning it on. To my surprise, the TV actually turned on, however the screen is blue and scrambled. I don't believe it's the mobo though because I am able to see fragments of a menu, change the volume, channel, input, etc. I've also reseated the components to see if maybe it was a loose connector.. No luck.

Anyone have any ideas or experience with this?
Mamoruanime is offline   Reply With Quote
Go Back   High Def Forum - Your High Definition Community & High Definition Resource > High Definition Viewing Mediums, HDTVs > Flat-Panel TVs
AddThis Social Bookmark Button
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -6. The time now is 02:06 AM.



Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2004 - 2008, High Def Forum